I guess renaming things like that will break existing code. Probably it is best to add more cross references or maybe add some nice starting examples so that folks can more easily find existing things. I'm happy to take ideas, especially based on where you looked but didn't find something or what kind of new examples would have helped you.
For some of my projects, I have created files with names such as should be racket. They contain simple compositions of Racket functions and renames that I consider better sign-posts for eventual readers. Consider starting a should-be-redex.rkt file where where-clause-acceptable-width is a renaming of metafunction-fill-acceptable-width. You may find that the former is the only name you use — in which case we should probably add this secondary name to redex — or you may find that you use it only once and then a local file is good enough.