Not getting an email code to register on

I'm trying to create an account on to submit a package but I'm not getting the email code at all. I enter my email and evaluate the anti-spam code and then it says that the code has been emailed. I tried 2 different emails on different services and checked my spam but there's nothing even after 2-3 hours. Not sure if this is the right place to make this kind of post. Any help is appreciated.

1 Like

Yep, this is definitely the right place to ask.

I just tried registering an account with a fresh email, and the code came to me right away. That suggests to me that the problem isn't with the mail generation, but instead the delivery. Is there any chance that the mail is being flagged as spam?

Yeah, okay, you said you checked for spam already, mea culpa.

Now I'm wondering ... if maybe it didn't work before, but it's working now? Ugh.

I just tried again and I'm still not getting any email. Not sure what I have to do, if there's even anything I can do.

Similar to @jbclements, I also just tried a test email, and the code arrived right away.

@Grafcube, perhaps there's some kind of deliverability issue with the address you tried...? If you have an alternate email address, it's worth trying that to see if it comes through there.

If it makes a difference, I tried it with my, and later gmail. The code arrived for my gmail about 6 hours later but I got nothing for the other two. I can't actually use my gmail though since it's for other purposes and I'd much rather use my disroot email for this.

I initially tried a Gmail account, which worked fine. Just now I've also tried Yahoo and a smaller third-party server, which have all worked as well.

I wonder if Disroot and Tutanota are blocking these messages, or conversely if they are being blocked by the email delivery layer... :thinking:

I have no idea how to proceed :person_shrugging:

I have been using both disroot and tutanota for a long time and I've never really had any issues. I don't know if this is related but I just checked and it actually took over 8 hours for the code to arrive on gmail.

We had a similar problem in the university. Some email providers have a very strong spam filtering and send the messages to void instead of the spam folder, without a bouncing email. (I think hotmail/live/outlook was the most problematic.)

Sometimes it gets solved if you send an email in the opposite direction. If the server wants to send a message from to a person, sometimes the problem is fixed if the person sends a message from to

(The content of the message is not important. It just add the other address to the well known list of the person.) YYMV.

I sent an email to and tried to register again about 15 minutes ago. I haven't got anything yet and idk if it will arrive later if at all.

I see it in the logs. We deliver via a gmail SMTP relay, and it accepted it (SMTP 250). I don't think I have credentials to look into the internals of the gmail configuration to see what happened then - but I would expect some kind of bounce message if it wasn't deliverable. Let me try sending you a message directly from my personal gmail account.


I emailed you directly. Do let me know if you get it! Also, I tried mailing the package server itself, to test the reply path - nothing has come through, so perhaps we're not seeing bounces etc anymore.

1 Like

I received your email without any issues.

Email is like democracy. It's the worst possible system except for all of the others that are even worse.

Speaking from experience, SMTP forwarders can sometimes impose their own hidden blacklists. @tonyg , can you not send an email using the same SMTP pathway that the registration emails send?

Or in this case, maybe it would just be simpler to generate the darn code and email it to @Grafcube manually?

Bump? @tonyg ?

Ooh, post must be at least 20 characters.

It still doesn't work and I have no idea what to do. Any advice?

Hello hello @tonyg @jeapostrophe @samth does the code live in some repo? I'm not sure who has the keys to this particular car.

See GitHub - racket/racket-pkg-website: A frontend for the Racket Package Catalog.

I took a look at the SPF record for

$ dig txt

; <<>> DiG 9.18.4-2ubuntu2-Ubuntu <<>> txt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22406
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 65494
;               IN      TXT

;; ANSWER SECTION:        300     IN      TXT     "v=spf1 ?all"

;; Query time: 288 msec
;; WHEN: Sun Feb 05 23:49:00 EST 2023
;; MSG SIZE  rcvd: 68

The ?all at the end of the record means that SPF verification will give a "neutral" result: and, indeed, I looked up the registration message I got way back when, and the SPF status was "neutral".

Since messages are being sent through a Gmail relay, I think it would be better to set the SPF record to:

"v=spf1 ?all"

where means that mail from the IP address ranges used by Google (reference) will instead "pass" authentication, while mail from other addresses will continue to be "neutral".

That should help deliverability of mail sent through the Gmail relay without changing anything for mail sent by other means.

1 Like