DrRacket help function not working on MacOS Monterey

I'm new to Racket. On macOS Monterey, I installed Racket, DrRacket etc. by downloading the dmg file and installing it into /Applications. It seems to work but I can't get the help function to work. I put the cursor on a function name and press F1. This pops up a Safari window (title bar lists a file "file:///private/var/folders/ss/5nm90hsn5x745_n8jc5683ym0000gn/T/plt-sendurl-contents-file-16749376611674937661347.html". that displays "please go here" which contains a URL "file:///Applications/Racket%20v8.7/doc/search/index.html?q=remainder". However, when I click on here nothing happens.

If I copy the url and paste it into another tab it does go to the help location. However, that's a very annoying way to get help.

From what I've read seen on videos clicking F1 on a function should directly open the help in the browser with no additional help from me.

Am I doing something wrong? Has anyone gotten this to work on MacOS? Perhaps Apple has made a recent "security enhancement" to Safari .

I tried both the Racket 8.7 from Racket-lang.org and also the one from Homebrew. Both have the same problem.


Try this:

1 Like

That fixed it! Thank you for the help.

1 Like